Schwarzer Bildschirm nach Anmeldung am Terminalserver

 

Den Dienst „App-Vorbereitung“ stoppen
Stop-Service AppReadiness
Registry öffnen: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\Config
Dirt den Schlüssel „Microsoft.Windows.ShellExperienceHost_*******“ umbenennen (zum Beispiel ein „.backup“ anhängen oder den Schlüssel exportieren und löschen)
Die „App-Vorbereitung“ wieder starten
Start-Service AppReadiness
Maschine rebooten und neu anmelden. Die Wartezeit sollte nun der Vergangenheit angehören.

 

Symptome

Direkt nach der Anmeldung zur RDS-Sitzung wird ein schwarzer Bildschirm angezeigt:

Ursache

Die Aktivität des Windows App-Vorbereitungsdienstes blockiert die Darstellung des Desktops. Möglicherweise ist dies auf einen anderen Fehler zurückzuführen.

Bestätigt, dass dies in Benutzerprofil-Datenträger und AVD + FSLogix-Umgebungen auftritt. Möglicherweise wird es beim normalen RDS nicht bemerkt, da dieser weniger betroffen ist.

Lösung

Beenden und deaktivieren Sie den App-Vorbereitungsdienst. Die Anmeldezeit sollte sich nach dieser Änderung verbessern.

HINWEIS: Der App-Vorbereitungsdienst muss möglicherweise vor der Installation von Windows Updates, die einen Neustart erfordern, gestartet werden.

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